AnyShare-AnyShare 7.0 富客户端无法上传下载文件,日志显示:Database Init Error
简介:AnyShare 7.0 富客户端无法上传下载文件,上传文件一直处于等待中,下载文件无响应,web 端和同步盘正常,富客户端日志显示:Database Init Error。
关键字
富客户端、cache.json
适用产品
- AnyShare Enterprise 7.0.x
- AnyShare Express 7.0.x
问题描述
AnyShare 7.0 富客户端无法上传下载文件,Web 客户端和同步盘使用正常,查看富客户端日志显示:
Database Init Error
问题影响
AnyShare 7.0 富客户端无法上传下载文件。
问题原因
富客户端上传下载文件会将同步信息写入到配置文件中的 cache.json 文件中,若因 cache.json 格式错误等原因无法加载,则富客户端无法上传下载文件。
解决方案
为了解决该问题,需要重命名富客户端配置目录,重新生成配置文件,请按照以下步骤执行:
1.退出客户端。
2.按 Win + E 键打开文件资源管理器,输入 %appdata%,按下 Enter 键跳转至配置文件目录。
3.右键点击目录中的 AnyShare 文件夹,点击重命名,修改文件夹名称,下图示例中,将文件夹重命名为 AnyShare1。
4.重新登录客户端。
更多信息
- AnyShare 文件夹被重命名后,在重新登录时会生成新的 AnyShare 文件夹,此时配置文件已经重新生成。重新登录 AnyShare Windows 客户端时,需要重新输入 AnyShare 服务器地址。
- 富客户端日志文件位置为 %appdata%\AnyShare\RichClientLog\AS.log。