AnyRobot-AnyRobot 3.0 使用网易 163 或 126 邮箱配置 SMTP 服务器,点击保存失败,提示错误信息:请检查 SMTP 服务器或端口是否正常
关键字
SMTP 服务器、邮件告警
适用产品
- AnyRobot 3.0.0 - 3.0.12
问题描述
在 AnyRobot 3.0 使用网易 163 或 126 邮箱配置 SMTP 服务器,点击保存失败,弹出错误对话框,详细错误信息如下:
连接远程 SMTP 服务器失败,请检查邮件服务器和端口是否正确
问题影响
配置 SMTP 服务器无法正常发送邮件。
问题原因
此问题可能原因为下面两者之一:
- AnyRobot 3.0 添加 SMTP 服务器的邮箱,需要将用于邮件转发的网易 163 或 126 邮箱开启 POP3/SMTP 服务,使用客户端授权码的方式进行验证邮箱,而客户输入的是邮箱登录密码。
- AnyRobot 3.0 添加 SMTP 服务器的邮箱,无法访问 SMTP 服务器地址。
解决方案
为了解决该问题,需要在 SMTP 配置页面的密码栏输入客户端授权码作为验证密码,保证 SMTP 服务器地址正常访问。请按照以下步骤执行:
方案一,需要在 SMTP 配置页面的密码栏输入客户端授权码作为验证密码。
1. 登录网易 163 或 126 邮箱,依次点击设置 > 客户端授权密码标签页,选择开启客户端授权,并输入对应的授权码。
2. 依次点击设置 > POP3/SMTP/IMTP 标签页,勾选 POP3/SMTP 服务器。
3. 使用 admin 用户登录 AnyRobot 管理控制台,依次点击系统设置 > 系统配置 > 系统配置 > SMTP 配置 ,在密码栏输入客户端授权码。
4. 重新进行 SMTP 配置,点击保存。
方案二,保证 SMTP 服务器地址正常访问。
1. 通过 SSH 工具登录到 AnyRobot 管理控制台的操作系统。
2. 尝试执行 ping <SMTP 服务器地址> 命令,提示主机域名没有解析,无法访问。
3. 给服务器配置 DNS 地址,执行 vi /etc/resolv.conf 命令编辑配置文件。
4. 按 i 键,添加 DNS 服务器地址,如 nameserver 114.114.114.114,然后按 ESC 键, 输入 :wq 保存。
5. 添加 DNS 服务器地址后,再次执行 ping <SMTP 服务器地址> 命令,主机域名正常解析,访问正常。
6. 重新进行 SMTP 配置,点击保存。
更多信息
客户端授权码是指:为每个客户端(如 PC 上的 Outlook、移动设备上的邮件 APP)设置专属的授权密码,用授权码代替邮箱密码登录客户端,即使邮箱密码丢失,邮件也不会通过客户端泄露。