AnyBackup-阿里云定时备份失败,备份初始化失败,没有权限或权限不足
关键字
阿里云、权限不足
适用产品
- AnyBackup CDM 7.0.18
- AnyBackup Enterprise 7.0.18
- AnyBackup Express 7.0.18
问题描述
AB7.0.18环境,针对阿里云备份执行输出报错,备份初始化失败,没有权限或权限不足。
备份初始化失败,没有权限或权限不足。
问题影响
无法发起备份,备份失败。
问题原因
AB7.0.18.0备份阿里云专有云更改了对接方式,需要租户有 RAM 权限。
解决方案
为了解决该问题,需要在阿里云平台上创建新的用户赋予 RAM 权限,然后在 AnyBackup 控制台上利用阿里云新用户生成的 AK/SK 编码编辑原来的爱数租户:
1.使用阿里云账户登录 RAM 控制台。
2.在左侧导航栏,选择身份管理>用户。
3.在用户页面,单机创建用户。
4.在创建用户页面的用户账户信息区域,设置用户基本信息。
登录名称未方案商可使用的登录账户;显示名称可设置未方案上名称,例如“方案商 AISHU ”。
5.在访问方式区域下,选择控制台访问或 Open API 调用访问。
a.控制台访问:若 RAM 用户代表人员,建议启用控制台访问,使用用户名和密码访问阿里云。
控制台密码:选择自动生成密码或者自定义密码。自定义登录密码时,密码必须满足密码复杂度规则。更多信息,请参见设置 RAM 用户密码强度。
密码重置策略:选择在下次登录时是否需要重置密码。
多因素认证(MFA)策略:选择是否为当前 RAM 用户启用 MFA 。选择启用 MFA 后,RAM 用户登录控制台时,需要绑定 MFA 设备。更多信息,请参见为 RAM 用户启用多因素认证。
b.Open API 调用访问:若允许方案商的云端应用程序连接到物联网平台进行设备管理,则选中复选框,自动为该 RAM 用户生成访问密钥(AccessKey)。
6.单击确定,通过阿里云账号注册手机验证并通过后,创建完成 RAM 用户。
注意:关闭该页面后无法再查看 AccessKey ID 和 AccessKey Secret 信息。因此,请一定要单击复制或下载 CSV 文件,保存 RAM 用户信息到本地。
7.登录 admin 用户,在资源,云平台模块上找到对应的阿里云平台。
8.使用第六步创建新用户生成新的 AccessKey ID,使用新的 AK 或 SK 编辑云平台租户。
9.确认保存后,重新发起备份。
更多信息
AnyBackup 升级到7.0.18版本之后,阿里云平台需要将所有租户重新编辑,避免使用故障。