为了给您提供更优质的服务,请您先完善以下信息:
确认提交

扫码关注

爱数技术支持中心公众号

请选择:

请选择咨询类型

AnyShare
AnyBackUp
AnyRobot

扫码关注

爱数技术支持中心公众号

contact us

提交成功!

我们将在 24 小时之内联系你。

技术知识库
KB ID
KB-1457
发布时间
2021-09-10
分类
排错指南
产品
AnyShare

AnyShare-AnyShare 6.0 登录 Windows 客户端一直提示更新

关键字

版本、更新

适用产品

  • AnyShare Enterprise 6.0.x
  • AnyShare Express 6.0.x
  • AnyShare Cloud 6.0.x

问题描述

打开 AnyShare Windows 客户端,输入用户名和密码后,点击登录提示 爱数 AnyShare Enterprise 更新,点击 立即更新 后再次登录客户端仍会提示 爱数 AnyShare Enterprise 更新

问题影响

AnyShare Windows 客户端每次登录都会提示更新客户端。

问题原因

AnyShare 系统管理控制台上传的 Windows 客户端升级包命名的版本和客户端实际版本不一致。AnyShare Windows 客户端在登录时会检查客户端是否需要更新,会将获取到的客户端升级包命名的版本信息作为参数传入,若命名的版本与客户端实际的版本与其不一致就会提示 AnyShare 更新。

解决方案

为了解决该问题,需要修改上传客户端升级包命名的版本与客户端一致,请按照以下步骤执行,以 AnyShare Enterprise 6.0.13 的环境为例:
1. 选中客户端安装包,单击鼠标右键,选择 属性
2. 选择 详细信息 标签页,确定 文件版本
3. 修改客户端升级包包名中版本号相关信息,使其与安装客户端版本一致。
注意:上图示例仅做参考,若出现需要手动修改包名的情况,请按实际情况进行修改
4. 删除原错误客户端升级包。登录应用管理控制台,依次进入 部署管理 > 客户端 界面,点击 删除 按钮。
5. 点击 确定 按钮。
6. 上传客户端升级包。如下图,点击 浏览 按钮。
7. 选择第 2 步中命名正确的 AnyShare Windows 客户端,点击 打开 按钮。
8. 点击 保存 按钮。
9. 上传成功后界面如下图所示:
10. 将鼠标放在任务栏 AnyShare 图标上,点击右键选择 退出,重新登录客户端。

更多信息

若不确定 AnyShare Windows 客户端版本,还可以通过查看客户端安装目录下的 version.config 文件确定版本,如下图所示

需求助手 (内容由 AI 大模型生成,请仔细甄别)