AnyBackup-AnyBackup 7.0 因客户端系统时间与服务端系统时间相距较远导致客户端离线
关键字
客户端离线、系统时间
适用产品
- AnyBackup CDM 7.0.17.1-7.0.17.3
- AnyBackup Express 7.0.17.1-7.0.17.3
问题描述
- 客户端服务正常,客户端和服务端网络通信正常,端口均已放通,客户端和服务端 ssl 配置一致,客户端是离线状态。
- 在/var/log/AnyBackup/ABClientService/AggregateApp/clientsvc.log中显示如下信息:
remote error:tls:bad certificate
问题影响
客户端离线。
问题原因
客户端系统时间与服务端时间相差很大,SSL 会因证书验证失败而无法连接导致客户端离线。
解决方案
为了解决该问题,需要修改系统时间,使得客户端与服务器系统时间一致,以 Linux 操作系统为例,请按以下步骤操作:
1.通过 SSH 工具登录 AnyBackup 服务端的 Linux 操作系统,执行以下命令,查看当前正确的系统时间和时区。
date
2.通过 SSH 工具登录 AnyBackup 客户端的 Linux 操作系统,执行以下命令,将客户端系统时间设置成与服务端系统时间一致,设置时区与服务端时区相同。
date -s “1990-12-12 12:12:12“ #具体时间请以第一步获取到的服务器时间作为参考
tzselect #修改时区,选择Asia/China/Beijing Time,然后确认
ln -sf /usr/share/zoneinfo/Asia/Shanghai /etc/localtime #使修改的Asia/Shanghai时区配置生效
3.执行以下命令,将当前时间和日期写入硬件。
hwclock -w
更多信息
在 SSL 握手过程中,会向对方传送本机的系统时间。SSL 证书中有一个有效时间段,当客户端或服务器的系统时间不在这个时间段内时 SSL 会因证书验证失败而无法连接,当没有 NTP 服务器无法自动校准时间时可能会导致系统时间设置有误。